Slowness and connection issues for EU accounts
Incident Report for Lever
Resolved
The connection issues that were affecting customers on EU accounts have been resolved. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Jul 07, 2021 - 10:51 PDT
Monitoring
A fix has been implemented for the issue causing slowness in EU accounts. We’re currently monitoring to ensure that there are no further issues and we’ll send a final update to confirm that there have been no recurrences.
Posted Jul 07, 2021 - 10:19 PDT
Investigating
We are currently investigating an issue that's causing slowness and connection problems for customers on EU accounts. We became aware of this issue at 8:45 AM PDT and affected users might see a spinning wheel when navigating between pages and increased loading times. We’re working to identify the issue and put a resolution in place as soon as possible.
Posted Jul 07, 2021 - 08:45 PDT
This incident affected: EU Data Center - LeverTRM (Hire).