Degraded Services - scheduling, interview panel updates, offers
Incident Report for Lever
Resolved
We were able to identify and resolve the issue. Functionality is back to normal. Users may have experienced issues with calendaring and scheduling between 4:42pm and 5:10pm.
Posted 5 months ago. Mar 12, 2019 - 17:23 PDT
Investigating
We are aware of an issue impacting scheduling, interview panel updates, and offers. We are currently investigating.
Posted 5 months ago. Mar 12, 2019 - 17:03 PDT
This incident affected: hire.