Scheduled Maintenance

Scheduled for Apr 28, 18:00 - 19:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 22, 2025 - 09:53 PDT

Scheduled

We will be undergoing scheduled maintenance to our EU and LTI Reporting databases during this time. We do not anticipate any customer impact during this maintenance window.
Posted Apr 22, 2025 - 09:51 PDT
This scheduled maintenance affects: Global Data Center - Advanced Analytics (Lever Talent Intelligence), EU Data Center - Advanced Analytics (Lever Talent Intelligence), Global Data Center - LeverTRM (Visual Insights), and EU Data Center - LeverTRM (Visual Insights).