500 Internal Server Errors
Incident Report for Lever
Resolved
Lever is fully operational for all users. We have successfully identified and resolved the root cause. Thank you for your patience as we worked to resolve this issue.
Posted Jul 26, 2017 - 16:37 PDT
Investigating
Lever's application is currently experiencing downtime. We are aware of the issue and are working toward a resolution.
Posted Jul 26, 2017 - 16:16 PDT