Some customers in Eastern Europe unable to access Lever
Incident Report for Lever
Resolved
This incident has been resolved. Please reach out to our Support team if you continue to have issues accessing Lever.
Posted Jul 16, 2020 - 14:15 PDT
Monitoring
We've received confirmation that affected companies are now able to access Lever, and we're monitoring for any residual impact at this time.
Posted Jul 16, 2020 - 08:04 PDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2020 - 03:46 PDT
Investigating
We are currently investigating an issue that is preventing customers in Poland and Lithuania from accessing Lever with a "This site can't be reached" error.
Posted Jul 16, 2020 - 03:37 PDT
This incident affected: EU Data Center - LeverTRM (Hire).