Cloudflare has implemented a fix for this issue and are currently monitoring.
Impact: Partial outage – a subset of users were unable to access Lever Some users may have received a “Site Not Found” error when accessing hire.lever.co and related pages.
We are continuing to work on a fix for this issue.
Posted Apr 17, 2026 - 10:36 PDT
Identified
Impact: Partial outage – subset of users unable to access Lever
We are investigating reports that some users receive a “Site Not Found” error when accessing hire.lever.co and related pages. This issue appears limited to a subset of customers and is related to an ongoing incident with our upstream network provider (Cloudflare):
Our systems are operating normally, but connectivity for some users is being impacted by this third‑party provider. We are monitoring their incident and will provide updates as more information becomes available.
There is currently no known workaround.
Posted Apr 17, 2026 - 10:33 PDT
Investigating
We are currently investigating this issue.
Posted Apr 17, 2026 - 10:15 PDT
This incident affected: Global Data Center - LeverTRM (Hire).