The issue causing Lever's Sandbox environment to go down has been resolved. The incident occurred from 10:45 AM to 12:36 PM PT on 8/14/2025. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Aug 14, 2025 - 12:37 PDT
Monitoring
A fix has been implemented for the issue causing Lever's Sandbox environment to be down. Customers should now be able to log in to sandbox environments. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Aug 14, 2025 - 12:19 PDT
Identified
We’ve identified the issue causing Lever's Sandbox environments to be inaccessible, and we’re working to implement a fix. Additional updates will be provided as soon as a resolution is in place.