Long load times and timeouts
Incident Report for Lever
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 11, 2019 - 13:09 PDT
Update
We are continuing to investigate the issue. We are seeing improved performance, but there may still be long load times.
Posted 7 months ago. Apr 11, 2019 - 10:16 PDT
Investigating
We are currently investigating an issue that is causing very long load times and timeouts.
Posted 7 months ago. Apr 11, 2019 - 10:09 PDT
This incident affected: hire.