Email drafts deleted when scheduling interview

Incident Report for Lever

Postmortem

Impact Summary 

Between October 22, 2025 and October 28, 2025, an issue with the Lever email-message-editor component caused the email body to be unintentionally cleared in several workflows, including the interview scheduler and offer editor. As a result, emails may have been sent without any body content, potentially leading to confusion or miscommunication with candidates and stakeholders. 

 _______________________________________________________________________________________________________

Root Cause 

An update was introduced to support upcoming functionality for the Candidate Transparency feature. This change altered how the email-message-editor initialized its content: 

 _______________________________________________________________________________________________________

Resolution 

  • On October 27, 2025, the issue was identified and diagnosed. 
  • A fix was implemented to restore the original behavior. 
  • The fix was deployed to production on October 28, 2025 at 17:11 ET, restoring expected functionality. 

 _______________________________________________________________________________________________________

 Preventative Actions 

To prevent similar issues in the future, improved regression testing will be implemented for shared components like the email-message-editor.

Posted Oct 30, 2025 - 05:36 PDT

Resolved

The issue where email drafts were removed when advancing through the interview scheduling process has been resolved. The incident occurred from October 16, 2025 at 9:41 AM to October 28, 2025 at 2:30 PM PT. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Oct 28, 2025 - 15:22 PDT

Investigating

We are currently investigating an issue that intermittently affects email drafts when scheduling interviews. Issues impacting Interview emails were noticed on Thursday 10/23/2025. Users may see their email drafts removed after viewing the preview page when scheduling an interview. Our Engineering teams are actively working to resolve this as soon as possible.
Posted Oct 27, 2025 - 09:28 PDT
This incident affected: EU Data Center - LeverTRM (Hire) and Global Data Center - LeverTRM (Hire).