Lever Sandbox Down

Incident Report for Lever

Resolved

The issue causing Lever's Sandbox environment to go down has been resolved.
Posted Dec 03, 2025 - 06:31 PST

Monitoring

A fix has been implemented for the issue causing Lever's Sandbox environment to be down. Customers should now be able to log in to sandbox environments. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Dec 03, 2025 - 06:13 PST

Investigating

We’ve identified a potential issue affecting Sandbox environment accessibility, and our team is currently investigating. We’ll share additional updates as soon as more information becomes available.
Posted Dec 03, 2025 - 05:50 PST
This incident affected: Sandbox.