500 Internal Server Errors
Incident Report for Lever
Resolved
Lever's application is back up and running for all users. If you continue to see any errors, don't hesitate to reach out to our team at support@lever.co and we'll be more than happy to help in any way we can.
Posted Oct 17, 2016 - 15:31 PDT
Monitoring
Lever's application is experiencing intermittent downtime. We are aware of the issue and are working toward a resolution.
Posted Oct 17, 2016 - 15:30 PDT