Reports Loading Errors
Incident Report for Lever
Resolved
The incident regarding loading reports is now resolved. If you experience any additional errors, don't hesitate to reach out to our team: https://help.lever.co/hc/en-us/requests/new
Posted Sep 21, 2016 - 10:23 PDT
Investigating
Users may be experiencing trouble loading Lever Reports. No data has been lost. We are aware of the issue and are working toward a resolution. We apologize for any inconvenience!
Posted Sep 21, 2016 - 09:14 PDT