Latency in Hire.lever.co

Incident Report for Lever

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2025 - 10:21 PDT

Investigating

We are currently investigating this issue.
Posted Mar 14, 2025 - 10:20 PDT

Monitoring

A fix has been implemented for the issue causing lag with some actions in Lever. Customers should start to see improved performance as the latency starts to catch up. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Mar 12, 2025 - 12:38 PDT
This incident affects: Global Data Center - LeverTRM (Hire).