Google Calendar errors impacting scheduling
Incident Report for Lever
Resolved
Google has confirmed that the issue with Google Calendar is resolved. More information on the incident can be found here: https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ. Users should no longer experience issues scheduling in Lever due to this issue.
Posted Sep 21, 2023 - 09:55 PDT
Identified
We have identified an issue with Google Calendar, affecting customers using G Suite for their calendar integration. Google is investigating, and you can see additional updates here: https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ. We became aware of this issue around 8 AM PT, and affected users may see errors such as "Something went wrong while updating calendar events." We will keep you updated as we continue monitoring this issue and await further information from Google.
Posted Sep 21, 2023 - 08:24 PDT
This incident affected: Third-Party Workflow Dependencies (G Suite Email/Calendar Integration).