Intermittent issues impacting Lever Hire
Incident Report for Lever
Postmortem

Our teams were alerted to an error impacting users ability to log on to Lever starting at approximately on July 22nd at 5:45 AM PT and ending at 6:15 AM PT. 

Our team quickly identified an issue related to an expired certificate for a Lever sub-domain resulting in errors for users when attempting to log in. The team restored the updated certificate and was able to resolve the issue. 

In order to mitigate future recurrence of the issue we reviewed the maintenance script updating the certificate and noted in some edge cases the expired certificate was not updated to the updated certificate as expected. Our team adjusted the maintenance script and processes to correct and mitigate this issue from recurring in the future.

Posted Jul 31, 2024 - 12:45 PDT

Resolved
The issue where users received an error when logging into Lever.co that was affecting customers has been resolved. The incident occurred from 5:45 AM to 6:15 AM. There should be no further impact at this time, but please reach out to us at Support if any additional assistance is needed.
Posted Jul 22, 2024 - 06:31 PDT
Monitoring
A fix has been implemented for the issue causing the log on error. Customers should now be able to log on. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Jul 22, 2024 - 06:22 PDT
Investigating
We are currently investigating an issue that is intermittently affecting users ability to access Lever. Users may may not be able to access Lever. Our Engineering teams are actively working to resolve this as soon as possible.
Posted Jul 22, 2024 - 05:45 PDT
This incident affected: Lever.co (Lever.co website).