Resume upload/download
Incident Report for Lever
Resolved
This incident has been resolved.
Posted Jan 14, 2019 - 18:11 PST
Investigating
We are currently investigating an issue with resume uploads and downloads.
Posted Jan 14, 2019 - 17:39 PST
This incident affected: EU Data Center - LeverTRM (Hire).