Candidate search issues

Incident Report for Lever

Monitoring

A fix has been implemented for candidate search issues. Customers should now be able to search candidates without any missing results. We’re currently monitoring to ensure that there are no further issues, and we’ll send a final update to confirm that there have been no recurrences.
Posted Nov 14, 2025 - 14:34 PST

Identified

We’ve identified the issue causing issues with candidate search results, and we’re working to implement a fix. Additional updates will be provided as soon as a resolution is in place.
Posted Nov 14, 2025 - 12:30 PST
This incident affects: Global Data Center - LeverTRM (Hire).