Reports of slowness and latency in Lever Hire
Incident Report for Lever
Resolved
The issues with slowness and latency have been resolved and there should be no further impact at this time. Our team is continuing to monitor this as we work to improve our overall system performance. Please reach out to Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new
Posted Jan 13, 2021 - 15:17 PST
Investigating
We are currently investigating an issue that's causing slowness and latency in Lever Hire. We’re working to identify the issue and put a resolution in place as soon as possible.
Posted Jan 13, 2021 - 10:24 PST
This incident affected: EU Data Center - LeverTRM (Hire).