Lever EU Production Maintenance

Scheduled for Aug 9, 22:30 PDT  -  Aug 10, 03:30 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 07, 2026 - 07:33 PDT

Scheduled

We will be performing upgrades on our Lever Production cluster starting at 10:30 PM PDT on August 9th. The maintenance window is expected to last approximately 5 hours, during which users may experience intermittent availability.
Posted Aug 07, 2026 - 06:58 PDT
This scheduled maintenance affects: EU Data Center - LeverTRM (Hire).