Offers not sending
Incident Report for Lever
Resolved
We have determined that the issue users were experiencing when attempting to send Offers was related to our DocuSign integration. Earlier today, DocuSign experienced downtime, and as a consequence it was not possible to send out Offers in Lever via the integration.

Now that this issue has been cleared https://status.docusign.com/, there should be no further impact, but please reach out to us at Support if any additional assistance is needed: https://help.lever.co/hc/en-us/requests/new.
Posted May 24, 2022 - 16:32 PDT
Investigating
We are currently investigating an issue that is affecting users from being able to send out offers. Affected users are receiving an error message when attempting to do so. Our Engineering teams are actively working to resolve this as soon as possible.
Posted May 24, 2022 - 12:55 PDT
This incident affected: Global Data Center - LeverTRM (Hire).