Email authentication error - Resolved

Incident Report for Lever

Postmortem

Incident Summary

On July 13, 2026, customers using Microsoft (Office 365) for email and calendar integration experienced service disruptions. Affected users were unable to authorize or re-authorize their email and calendar connections within Lever, often encountering an "Unknown error" message. Additionally, outbound emails sent through the Microsoft integration failed to deliver during this period. Google-based email and calendar services remained fully operational and were not impacted by this incident.

Detection

The issue was identified on July 13, 2026, at 2:22 PM ET, following reports from customers to our Support team. Upon investigation, the engineering team confirmed the failures and initiated a high-priority response. While the underlying technical expiration occurred on July 12, 2026, the impact became visible as users attempted to refresh permissions or send outbound communications the following day.

Root Cause

The incident was caused by the expiration of a digital security credential used to securely communicate with Microsoft. This credential acts as a secure "password" that allows our systems to sync email and calendar data. Because this was a shared credential used for the Microsoft integration, the expiration affected customers using Office 365 broadly rather than a specific account.

Resolution

To resolve the issue, our engineering team generated a new security credential and updated the integration settings across our environments. Once the new credential propagated through the system, service was fully restored. Restoration was verified through internal testing and confirmed by successful customer re-authorizations by 8:28 PM ET on July 13, 2026. No data loss occurred as a result of this incident.

Preventative Measures

To prevent a recurrence of this issue, we are implementing the following improvements:

  • Automated Expiry Tracking: We are establishing a formal tracking process for all integration credentials with automated reminders set well in advance of expiration dates.
  • Proactive Monitoring: New alerting has been configured to detect spikes in authorization failures, allowing our team to identify and resolve similar issues before they impact customers.
Posted Jul 22, 2026 - 06:20 PDT

Resolved

Issue Description: Users may have received an "Unknown error" when attempting to send emails or sync their Microsoft email and calendar in Lever.

Customer Impact: Affected users were unable to authenticate their Microsoft email and calendar integrations, blocking email sends to candidates and calendar sync functionality critical to recruiting workflows.

Status: Resolved — Email sends and calendar sync are now functioning normally. An RCA will be available within 7-10 business days.
Posted Jul 14, 2026 - 06:08 PDT

Monitoring

Mitigation steps have been applied and service functionality is returning to normal.
We are monitoring performance and stability.
Next update: upon resolution.
Posted Jul 13, 2026 - 17:28 PDT

Identified

We are continuing to investigate this issue.
Next update: 5:00 PM PT
Posted Jul 13, 2026 - 14:59 PDT

Update

We are continuing to investigate this issue.

Next update: 3:00 pm PT or sooner.
Posted Jul 13, 2026 - 12:57 PDT

Investigating

We are investigating an issue affecting Nylas authentication.

Users may experience an error message "Unknown error" when attempting to reset email/calendar integration permissions.
Start time: 10:10 am PT
Next update: 1:00 pm PT or sooner.
Posted Jul 13, 2026 - 11:04 PDT
This incident affected: Third-Party Workflow Dependencies (Microsoft Exchange (Nylas) Email/Calendar Integration).